08.09.2010

rtehtmlarea lädt nicht

Bei Benutzung des "Advanced Frontend Editing" (feeditadvanced) lädt der "htmlArea RTE" in Endlosschleife und gibt beim Speichern eine Fehlermeldung aus.

rtehtmlarea lädt nicht in feeditadvanced

rtehtmlarea lädt nicht in feeditadvanced

Fehlermeldung beim Speichern

Fehlermeldung beim Speichern

rtehtmlarea im Extensionmanager aufrufen

rtehtmlarea im Extensionmanager aufrufen

Javascript Kompression abschalten

Javascript Kompression abschalten

Umgehen kann man den Ladefehler, indem man das Vollbild-Icon anklickt.

Dann aber erscheint beim Speichern folg. Meldung:

SYSTEM ERROR: One or more Rich Text Editors on the page could not be contacted. This IS an error, although it should not be regular. You can save the form now by pressing OK, but you will loose the Rich Text Editor content if you do.

Dazu gibt es bereits eine Bugmeldung im TYPO3 Bugtracker.

Ab TYPO3 4.4.2 soll der Bug behoben sein.  In (nur) einer meiner 4.4.2 Installationen trat der Fehler dennoch auf.

"Schuld" war die Javascriptkompression im RTE, mit der der betreffende Server wohl nicht zurechtkommt.

Behoben werden konnte das Problem in dem Fall so:

  • Den Extensionmanager aufrufen,
  • RTEhtmlarea anklicken,
  • Häkchen entfernen bei "Enable compressed scripts",
  • "Update" anklicken,
  • Caches löschen

In meinem Fall ist der Fehler aufgetreten bei TYPO3 4.4.2, feeditadvanced 1.3.0 und 1.4.0, rtehtmlarea 2.0.3


Kategorie: Extensions, Fehlermeldungen, rtehtmlarea, feeditadvanced